You copied the Doc URL to your clipboard.

B Supported platforms

A full list of supported platforms and configurations is maintained on the Arm Developer website. It is likely that MPI distributions supported on one platform will work immediately on other platforms.

B.1 Performance Reports

See Supported platforms

Platform

Operating Systems

MPI

Compilers

x86_64

Red Hat Enterprise Linux and derivatives 6 and 7, SUSE Linux Enterprise Server 11 and 12, Ubuntu 14.04 and 16.04

Bullx MPI 1.2.7 and 1.2.8, Cray MPT (MPI/SHMEM), Intel MPI 4.1.x and 5.0.x, MPICH 2.x.x and 3.x.x, MVAPICH 2.0 and 2.1, Open MPI 1.6.x, 1.8.x (MPI/SHMEM), 1.10.x and 2.0.x, Platform MPI 9.x, SGI MPT 2.10 and 2.11, Spectrum MPI 10.1.0

Cray, GNU 4.3.2+, Intel 13+, PGI 14+

Arm®;v8 (AArch64)

Ubuntu 16.04, SUSE Linux Enterprise Server 12.2, and Red Hat Enterprise Linux 7.4

Open MPI 1.8.x, 1.10.x and 2.0.x

GNU

NVIDIA CUDA Toolkit 7.0/7.5/8.0

Linux

-

The Arm profiling libraries must be explicitly linked with statically linked programs which mostly applies to the Cray X-Series.

Batch schedulers: SLURM 2.6.3+ and 14.03+ (srun only).

Was this page helpful? Yes No