You copied the Doc URL to your clipboard.

3.2.2. Menu bar

The main menu bar provides access to most Model Debugger functions and commands.

File menu

The File menu has the following options:

Open Source ...

Opens the source code for the application.

Source File Manager ...

Displays the Source File Manager dialog.

Load Application Code ...

Loads application code to the model.

Load Application Code (Debug info only) ...

Loads debug information only.

Load Model ...

Loads a model.

Connect to Model ...

Displays the Connect to Target dialog to connect to a model file.

Close Model

Closes the currently open model. If Model Debugger is connected to a CADI server, Model Shell for example, the connection is closed but the simulation continues to run.

Open Session ...

Opens a previously saved session.

Save Session

Saves the current debug session.

Save Session As

Saves the current debug session to a new location and name.

Preferences

Displays the Preferences dialog to enable you to modify the user preferences.

Recently Opened Models

Displays a list of the most recently opened model files. Click on a list entry to open the file. By default, the last sixteen files are displayed in the list. The number of files to display can be set in the Preferences dialog.

To remove a file from the list, move the mouse cursor over the file name and press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Applications

Displays a list of the most recently opened applications. Click on a list entry to open the application. By default, the last sixteen applications are displayed in the list. The number of applications to display can be set in the Preferences dialog.

To remove a application from the list, move the mouse cursor over the application name and press the Delete key or right click and select Remove from list from the context menu.

Recently Opened Sessions

Displays a list of the most recently opened sessions. Click on a list entry to open the session. By default, the last sixteen sessions are displayed in the list. The number of sessions to display can be set in the Preferences dialog.

To remove a session from the list, move the mouse cursor over the session name and press the Delete key or right click and select Remove from list from the context menu.

Exit

Ends Model Debugger. If you have modified files or sessions, a dialog prompts you to save your changes.

Search menu

The Search menu has the following options:

Find ...

Opens a dialog that enables searching for a string in a currently active window.

Find Next

Repeats the last defined search to find the next occurrence.

Find Previous

Repeats the last defined search, but the search direction is backwards in the document.

Control menu

The Control menu has the following options:

Restart Simulation ...

This option restarts the simulation.

Reset

Click to cause a reset of the target model.

Goto Main

Cause a reset of the target model. The model runs until the main() function of the application source code is reached.

Note

This command is only available if a function main() can be found in the debug information of the application file.

Run

Run the simulation until a breakpoint is hit or some exception occurs. An example would be simulation halt.

Pause/Continue Source Step

Pause or continue the current high-level simulation step command. An example would be a source-level step.

Source Step Over

Cause a source-level step to execute until the simulation reaches a different source line.

Source Step Out

Cause source-level steps to execute control command until the current function is exited.

Instruction Step

Advance the simulation by executing one source-level instruction.

Instruction Step Over

Advance the simulation by one source-level instruction without following any call instructions.

Note

This command is not supported by all model targets.

Instruction Step Out

Advance the simulation until a return instruction is executed.

Note

This command is not supported by all model targets.

Instruction Step n

Advance the simulation by the number of instructions specified in the <- n -> edit box. The default is 1000 cycles.

Cycle Step

Advance the simulation by a single cycle.

Cycle Step n

Advance the simulation by the number of cycles specified in the edit box. The default is 1000 cycles.

Enable/Disable Step Back

Enable or disable stepping back by cycles.

Note

This command is not supported by all model targets.

Back

Step the simulation backwards by one cycle.

Note

This command is not supported by all model targets.

Back n

Step the simulation backwards by the number of cycles specified in the edit box. The default is 1000 cycles.

Note

This command is not supported by all model targets.

Debug menu

The Debug menu has the following options:

Display Messages

Display debug messages.

Clear Log

Clear the log of debug messages.

Clear Model Output

Clears all output messages from the model.

Clear Output Summary

Clear the summary output messages.

Breakpoint Manager ...

Display the Breakpoint Manager dialog.

Profiling Manager ...

Display the Profiling Manager dialog.

View Profiling ...

Display the Profile Information dialog.

Save Model State ...

Save the current model state. If reloaded, simulation continues from the point where the model state was saved.

Restore Model State ...

Reload a previously saved model state.

Load Debug Info for Module

Load debug information for the module.

Set Parameters

Set parameter values for the model.

Select Targets

Select the execution target within the model.

Layout menu

The Layout menu has the following options:

Layout Control Window

Display the Window to set layout options such as tiling.

Load Layout ...

Load a previously saved window layout.

Save Layout ...

Save the current layout. Model state is not saved.

Load Recent Layout

Use a recently used window layout.

Restore Default Layout

Restore the window layout to the defaults. This option is useful if the layout has become disorganized.

Window menu

The Window menu has the following options:

New View

Display a new debug view.

Hide

Hide an existing debug view.

Show

Display view that was most recently hidden.

Show All

Displays all previously hidden views.

Close

Close the window that currently has focus.

Arrange Horizontally

Tile all view windows horizontally.

Arrange Vertically

Tile all view windows vertically.

Move

Move a view to the new position specified on the submenu.

Docked Views

Dock or undock the views listed on the submenu.

Help menu

The Help menu has the following options:

Help ...

Opens this book in Adobe Acrobat Reader.

About ...

Displays the standard About dialog box displaying version and license information.

About Model ...

Opens the text file that contains the release notes.

Was this page helpful? Yes No