You copied the Doc URL to your clipboard.

Debug Hardware Firmware Installer view

Use the Debug Hardware Firmware Installer view to update the firmware for your debug hardware.

Firmware files for ARM® debug hardware units typically contain:

Templates for devices supported by the debug hardware unit
Each template defines how to communicate with the device and the settings that you can configure for that device. A firmware update might contain support for newer devices that the debug hardware unit can now support.
Firmware updates and patches
ARM periodically releases updates and patches to the firmware that is installed on a debug hardware unit. These updates or patches might extend the capabilities of your debug hardware, or might fix an issue that has become apparent.

To access the Debug Hardware Firmware Installer view, from the main menu, select Window > Show View > Other > DS-5 Debugger > Debug Hardware Firmware Installer.

Updating your debug hardware unit firmware using the Debug Hardware Firmware Installer view

  1. Connect your debug hardware to the client PC.
  2. From the main menu, select Window > Show View > Other > DS-5 Debugger > Debug Hardware Firmware Installer to display the view.
  3. Click Browse and select your debug hardware unit.
  4. Click Connect to your debug hardware unit.

    The current firmware status of your debug hardware is displayed. For example:

    Figure 11-65 Debug Hardware Firmware Installer view

    Debug Hardware Firmware Installer view

    Note In DS-5, the latest firmware files are available at: DS-5_install_directory\sw\debughw\firmware\. If you want to choose a different firmware file, click Browse and select the new location and file.
  5. Click Install. The firmware update process starts. When complete, a message is displayed indicating the status of the update.

Debug Hardware Firmware Installer view options

Select Debug Hardware
The currently selected debug hardware. You can either enter the IP address or host name of the debug hardware unit, or use the Browse button and select the debug hardware unit.
Browse
Click to display the Connection Browser dialog. Use it to browse and select the debug hardware unit in your local network or one that is connected to a USB port on the host workstation.
Identify
Click to visually identify your debug hardware unit using the indicators available on the debug hardware. On RVI, all LEDs on the front panel flash during identification. On DSTREAM, the DSTREAM logo flashes during identification.
Connect
Click to connect to your debug hardware. When connected, the dialog shows the current firmware status.
Select Firmware Update File
DS-5 automatically loads the firmware file supplied with your installation. If you want to use a different firmware file, use the Browse button and select the firmware file. When the file is selected, the dialog shows the selected firmware update file details.
Browse
Click to browse and select the firmware file.
Clear
Click to clear the currently selected debug hardware and firmware file.
Install
Click to install the firmware file on the selected debug hardware.

Firmware file format

Firmware files have the following syntax: ARM-RVI-N.n.p-bld-type.unit

N.n.p
Is the version of the firmware. For example, 4.5.0 is the first release of firmware version 4.5.
build
Is a build number.
Type
Is either:
base
The first release of the firmware for version N.n.
patch
Updates to the corresponding N.n release of the firmware.
unit
Identifies the debug hardware unit, and is one of:
dstream
For a DSTREAM debug and trace unit.
rvi
For an RVI debug unit.
Was this page helpful? Yes No