You copied the Doc URL to your clipboard.

About the Remote System Explorer

Describes the tab content.

The Remote Systems Explorer (RSE) enables you to:

  • set up Linux SSH connections to remote targets using TCP/IP

  • create, copy, delete, and rename resources

  • set the read, write, and execute permissions for resources

  • edit files by double-clicking to open in the C/C++ editor view

  • execute commands on the remote target

  • view and kill running processes

  • transfer files between the host workstation and remote targets

  • launch terminal views.

Useful RSE views that can be added to the DS-5 Debug perspective are:

  • Remote Systems

  • Remote System Details

  • Remote Scratchpad

  • Terminals.

To add a view to the DS-5 Debug perspective:

  1. Ensure that you are in the DS-5 perspective. You can change perspective by using the perspective toolbar or you can select Window > Open perspective from the main menu.

  2. Select Window > Show View > Other... to open the Show View dialog box.

  3. Select the required view from the Remote Systems group.

  4. Click OK.