You copied the Doc URL to your clipboard.

Streamline prerequisites

To run Streamline, your target hardware must be correctly configured.

Before configuring your target, ensure you have the following prerequisites for running Streamline:

  • An ARM®-powered hardware target.

  • The Linux kernel source code for the target platform. In DS-5 version 5.22, Streamline supports gator versions 16-22. gator version 22 only supports Linux kernel versions 3.4 and later. gator versions 21 and earlier support Linux kernel versions 2.6.32 and later.

    You need the Linux kernel source code for either of the following reasons:

    • If the Linux kernel is not properly configured for Streamline, you need to enable the required kernel configuration menu options and rebuild it.

    • If you want to use kernel space gator. This provides a more complete set of features than user space gator, but requires you to build the kernel module, gator.ko.

  • GCC to build the Linux kernel or gator.ko natively on the target, or to cross compile it on a Linux host. You can obtain GCC at the Linaro website: http://www.linaro.org, or, depending on the GCC version you require, from the DS-5 installation folder.

You do not need the Linux kernel source code or GCC if the kernel is properly configured and you are using user space gator. User space gator is supported for Linux kernel 3.4 and later.

Was this page helpful? Yes No