You copied the Doc URL to your clipboard.

Build requirements for Linux applications

All information in Building Linux Applications with the ARM Compiler toolchain and GNU Libraries relates to the use of the ARM Compiler toolchain.

The CodeSourcery 2005-q1 release was the first to permit Embedded Application Binary Interface (EABI) compliant interoperation between ARM Compiler toolchain and the GNU toolchain. However, several enhancements and fixes have been made since the CodeSourcery 2005-q1 release. Therefore, ARM recommends that you only use the CodeSourcery 2008q1 or later releases for interoperating with the ARM Compiler toolchain, and the instructions in this document relate only to these releases.

Therefore, the instructions in this document relate only to the CodeSourcery 2006-q1-6 and later releases, because it is now simpler and safer to link with a newer release.

Your ARM Linux distribution might already use the CodeSourcery toolchain or have the appropriate patches applied. For more details, contact your ARM Linux distributor.