You copied the Doc URL to your clipboard.

2.3.1. Installation requirements for Linux

The following are required for Linux platforms:

  • Ubuntu Linux version 10.04

  • a minimum of 40MB disk space to install the Mali SDK library and applications.

  • Ant (version 1.8 or above) from http://ant.apache.org/

  • Android SDK (revision 17 or above) from http://developer.android.com/sdk/index.html

  • Android NDK (revision 7b or above) from http://developer.android.com/sdk/ndk/index.html

  • Java JDK from http://www.oracle.com/technetwork/java/javase/overview/index.html.

    • The jarsigner tool supplied with Java SE 7 is not usable with the Mali SDK for manually signing non-debug releases.

    • Use the jarsigner file supplied with Java SE 6 to manually sign releases.

  • the Khronos OpenGL ES and EGL libraries (these are included in the Android NDK)

Note

You can use the version 3.5 or later of the Eclipse environment, but all of the samples can be build from the command line.

Was this page helpful? Yes No