You copied the Doc URL to your clipboard.

Target System Requirements

In general, the Mali Graphics Debugger should work on any Linux system that supports one or more of the following:
  • OpenGL ES 2.0, 3.0, 3.1, or 3.2 and EGL 1.4
  • OpenCL 1.0, 1.1, and 1.2
The system should be able to substitute the existing OpenGL ES, EGL, and OpenCL system libraries with the supplied interceptor libraries. The specific method for doing this is platform-specific.
In addition, this version of MGD has been tested with:
  • Android™ 5.0 and 5.1 on a consumer tablet
  • Android 6.0 on a consumer phone
  • Android 7.0 and 7.1 on an internal development board
Previous versions of MGD have been tested with:
  • Android 4.2, 4.3, and 4.4 on a consumer tablet
Other platforms should also work correctly although these have not been tested.

The professional edition of MGD is required for support of target systems using non-Mali GPUs.

Was this page helpful? Yes No