Combined C/C++ and Debug Perspectives

Arm Development Studio comes with a new IDE perspective, called Development Studio.  This is the default view when Arm Development Studio opens.

 

This perspective combines the views of the DS-5 C/C++ and the DS-5 Debugger perspectives.

Explore the Development Studio perspective:

  1. Click the Import Project icon in the Project Explorer.
    Note: The Import Project icon is only present if no projects are listed in the Project Explorer view.

     
  2. Expand Arm Development Studio.
    Arm Development Studio allows you to convert and import existing uVision projects.  There is more information on this topic later. 

     
  3. Click Cancel to exit the Import Project view.
  4. Click View Menu (three line icon) at the top of the Project Explorer view.
    Note: To display menu items for the view, Arm Development Studio uses a three line icon instead of the inverted triangle used in DS-5.

     
  5. Click anywhere outside the View Menu list to exit the menu.
  6. Click the New Debug Connection icon in the Debug Control view.
    Note: The New Debug Connection icon is only present if no launch configurations exist in Arm Development Studio workspace.
    Arm Development Studio provides new methods to create Hardware, Linux Application, and Model connections. These new methods are discussed in the connection creation sections of this guide.

     
  7. Click Cancel to exit the New Debug Connection view.
  8. Click the Connect with Existing Config icon.
    Note: The Connect to Existing Config icon is only present if no launch configurations exist in Arm Development Studio workspace.
    The Connect with Existing Config view is empty, unless you have already created launch configurations with Arm Development Studio.

     
  9. Click Cancel to exit the Connect with Existing Config view.

Click the '+' to add other views to the Development Studio perspective, or select Window > Show View and choose your view.

Unlike DS-5, Arm Development Studio has Builds the selected project (hammer) and Cleans the selected project (broom) icons in the Project Explorer view to build and clean the selected project respectively.

Previous Next