License Manager

Unlike DS-5, before the IDE opens, if no license file information exists, Arm Development Studio prompts you to get or enter a license file, and select a tools edition.  This activity describes how to add an existing license server.

Add a license to Arm Development Studio:

  1. Open Arm DS IDE 2019.0.
    If no product license information exists for Arm Development Studio, you see the following dialog:

     
  2. Note: You can skip adding a license to Arm Development Studio by clicking Skip. If you do so, some of the Arm Development Studio IDE functionality will be unavailable. You can add a license to Arm Development Studio in the future by navigating to the Arm License Manager (Window > Preferences > Arm DS > Product Licenses). This activity assumes adding a license to Arm Development Studio is not skipped.
  3. Select Add product license and click Next.
  4. Under License Server, enter the license server port and address.

     
  5. Click Next.
  6. Select the appropriate Arm Development Studio edition from the provided list.
    Note: Only editions enabled by the license file will be made available.

     
  7. Click Next and then click Finish.
Changes to Arm Development Studio license(s) are done through Help > Arm License Manager or Window > Preferences > Arm DS > Product Licenses.
Previous Next