Error messages when installing Arm Compiler for Linux

Should you experience a problem when installing Arm Compiler for Linux, consider the following points:

  • To perform a system-wide install, ensure you have adequate permissions. If you do not have the adequate permissions, the following errors are returned:
    • Systems using RPM Package Manager (RPM):

      error: can't create transaction lock on /var/lib/rpm/.rpm.lock (Permission denied)
    • Debian systems using dpkg:

      dpkg: error: requested operation requires superuser privilege
  • If you install using the --install-to <directory> option, ensure the system you are installing on has the required rpm or dpkg binaries installed. If it does not, the following errors are returned:
    • Systems using RPM Package Manager (RPM):

      Cannot find 'rpm' on your PATH. Unable to extract .rpm files.
    • Debian systems using dpkg:

      Cannot find 'dpkg' on your PATH. Unable to extract .deb files.