FlexNet licensing error -83: FLEXnet Licensing version of client newer than server

Arm Compiler 5.06 update 5 includes FlexNet Publisher 11.14.1.0 client libraries.

This version of the license client is not compatible with previous versions of the FlexNet Publisher license server software. When used with a license server running an armlmd or lmgrd version earlier than 11.14.1.0, Arm Compiler 5.06 update 5 can report either of the following:

  • Failed to check out a license. Bad message command.

  • Failed to check out a license. Version of vendor daemon is too old.

  • Flex error code: -83.

  • Flex error code: -140.

A license server running armlmd and lmgrd version 11.14.1.0 (or later) is compatible with Arm Compiler 5.06 update 5 and all previous releases of Arm tools. Arm recommends that you always use the latest version of the license server software that is available from Download FlexNet Publisher.